Pada project kali ini, klien kami mempunyai request untuk menggabungkan 2 isp ke dalam 1 routerboard. Berbeda dengan kasus sebelumnya yang relatif mudah karena menggunakan protokol BGP dan seluruhnya menggunakan IP public, kasus ini cukup menantang karena kedua ISP tersebut memberikan IP publik point-to-point sementara komputer klien menggunakan IP private sehingga ketika mengakses internet maka router perlu melakukan NAT untuk mentranslasikan IP private ke IP public. Agar lebih jelas dalam memahami kondisi jaringan, kita memerlukan gambar topologi jaringan yang dapat dilihat pada gambar di bawah:

menggabungkan 2 isp kedalam satu routerboard

Jadi, rencana implementasi teknisnya adalah:

  • Komputer yang ada di LAN akan mengakses internet via ISP1 atau ISP2. diharapkan bandwidth yang dikonsumsi oleh kedua ISP adalah sama, ini berarti kita perlu melakukan load balancing (penyebaran beban) pada koneksi ISP yang ada.
  • Datarate ISP1 adalah 5 mbps, ISP2 adalah 5mbps
  • RouterOS mendukung algoritma load balancing pada level-connection (misal: PCC – per connection classifier) dan level-packet (misal: nth). karena kita menggunakan NAT, maka kita akan menggunakan level connection dengan classifier (pembeda) adalah source IP address. ini artinya setiap IP address di LAN akan di mapping ke koneksi outgoing yang ada. teknisnya, kita akan menggunakan firewall mangle untuk melakukan marking routing pada koneksi yang ada.
  • setelah packet dimarking, proses selanjutnya adalah “routing decision” yaitu membaca routing table yang menentukan kemana paket ini akan diforward. Teknisnya, kita akan membuat sebuah routing entry yang memforward paket ke gateway tertentu berdasarkan routing mark yang menempel padanya.

bagaimana contoh command linenya?

#membuat PCC
/ip firewall mangle add chain=prerouting dst-address=!192.168.5.0/24 in-interface=ether3 connection-mark=no-mark per-connection-classifier=src-address:2/0 action=mark-connection new-connection-mark=conn-isp1
/ip firewall mangle add chain=prerouting dst-address=!192.168.5.0/24 in-interface=ether3 connection-mark=no-mark per-connection-classifier=src-address:2/1 action=mark-connection new-connection-mark=conn-isp2

#marking routing
/ip firewall mangle add chain=prerouting connection-mark=conn-isp1 action=mark-routing new-routing-mark=via-isp1
/ip firewall mangle add chain=prerouting connection-mark=conn-isp2 action=mark-routing new-routing-mark=via-isp2

#marking routing
/ip route add dst-address=0.0.0.0/0 gateway=ether1 check-gateway=ping routing-mark=via-isp1
/ip route add dst-address=0.0.0.0/0 gateway=ether2 check-gateway=ping routing-mark=via-isp2

selesai. Saat ini, kita telah menggabungkan 2 isp ke dalam 1 routerboard. jika ada masukan dipersilahkan 🙂

5 Comments

  • Thabo Pienaar

    Thanks!
    I’ve tried adding some PCC rules to force YouTube uploads to one of my ISP links which provide better upload speed, but its not working.
    And then, I also would like to prioritise VOIP traffic – also those rules are not working. Could you assist?

  • Jimmy

    ada solusi kalau mau buat webserver biar bisa diakses dari jaringan luar ?
    misal web server pake ipcloud isp1 forward ke web server lokal tapi hasinya koneksi refused
    kalo loadbalance di disable bisa, default route ke isp1

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.